Jump to content


Photo

Side Case Install Question


  • Please log in to reply
8 replies to this topic

#1 nervous

nervous

    FJR Pilot

  • Members++
  • PipPipPip
  • 235 posts
  • Gender:Male
  • Location:Central, NY
  • 2009 ABS (Gen II) N. America

Posted 01 April 2012 - 01:51 PM

Quick question, is it normal for there to be a significant resistance and eventual 'snap' in the last 1/3 rd or so of the side case handle travel when installing the cases? It seems as if it could be damaging to the mechanism on both install and removal but if you tell me it's all good I'll move on.

#2 FJR Bill

FJR Bill

    FJR Pilot

  • Members++
  • PipPipPip
  • 386 posts
  • 2009 ABS (Gen II) World

Posted 01 April 2012 - 02:02 PM

Quick question, is it normal for there to be a significant resistance and eventual 'snap' in the last 1/3 rd or so of the side case handle travel when installing the cases? It seems as if it could be damaging to the mechanism on both install and removal but if you tell me it's all good I'll move on.

The most important thing is to make sure the case is lined up correctly in the upper slots and the lower tangs are also properly seated on the rubber mount. If all is well on those 3 points you will feel a snap as you described which is a caming action of the lock mechanism. Good luck, Bill

#3 Bogus

Bogus

    FJR Squadron Leader

  • Members++
  • PipPipPipPip
  • 516 posts
  • Gender:Male
  • Location:Dubuque, IA
  • 2014ES (Gen III) N. America

Posted 01 April 2012 - 05:08 PM

Also, the more you take them on and off, the easier they operate.

#4 gixxerjasen

gixxerjasen

    FJR Commander

  • Members++
  • PipPipPipPipPip
  • 2,221 posts
  • Gender:Male
  • Location:DFW
  • 2007 ABS AE (Gen II) N. America

Posted 01 April 2012 - 08:32 PM

Make sure you have the lower rubber mount inserted correctly into the fins on the bag. First time I tried to mount my bags I was running into the same thing you are and my father in law pointed out the lower parts needing lined up that I'd ignored. When you are mounting the bag they are obstructed from your view and easy to not notice if you aren't used to doing it. After a few tries they were going on and off super easy.

#5 juniorfjr

juniorfjr

    FJR Commander

  • Members++
  • PipPipPipPipPip
  • 1,389 posts
  • Gender:Male
  • Location:Wenatchee, WA
  • 2005 ABS (Gen I) N. America

Posted 01 April 2012 - 09:47 PM

On my 05 with 50k on it, I've recently noticed a similar problem. Like the mechinism is hanging up. It'll go just be careful. And if you figure it out let us know..

IBA #37992, Darksider #32
WFO 4, WFO 5, WFO 6, WFO 8, WFO 9, CFR 09, WCR 10, WTFO 10, NAFO 12, REUBEN RUN


#6 nervous

nervous

    FJR Pilot

  • Members++
  • PipPipPip
  • 235 posts
  • Gender:Male
  • Location:Central, NY
  • 2009 ABS (Gen II) N. America

Posted 02 April 2012 - 03:58 AM

Thanks all!

#7 Mount Rainier

Mount Rainier

    FJR Pilot

  • Members++
  • PipPipPip
  • 494 posts
  • Gender:Male
  • Location:Kent, WA
  • 2008 ABS (Gen II) N. America

Posted 02 April 2012 - 06:24 AM

You might consider this MOD as well. Riding year round had it's challenges relating to your issue. Mine was grit and sand finding it's way into the moving parts. This solved it nicely.

Keep Going!
100K%2008CLUB.jpg   

#8 Sharif

Sharif

    FJR Pilot

  • Members++
  • PipPipPip
  • 334 posts
  • Gender:Male
  • Location:Granger, IN
  • 2006 ABS (Gen II) World

Posted 05 April 2012 - 07:24 PM

Thx for he mod link
The ripple has begun...
IBA #44614
Posted ImagePosted Image

#9 FJR Flyer

FJR Flyer

    DC Commuter Commando

  • Members++
  • PipPipPipPip
  • 708 posts
  • Gender:Male
  • Location:Maryland
  • 2006 ABS (Gen II) World

Posted 06 April 2012 - 03:34 AM

You might consider this MOD as well. Riding year round had it's challenges relating to your issue. Mine was grit and sand finding it's way into the moving parts. This solved it nicely.

Keep Going!


+1 on this mod! I had one case that was almost jammed. Got it cleaned out and working well, but didn't want it to happen again. Since using this mod, I haven't had the problem reoccur.
Chris P. IBA#37903
'06 FJR1300, '87 FJ1200, '76 DT250
Posted ImagePosted Image